Installing Crystal Reports 2008 Developer for Epicor 9.05 and Label Format Issues

Here we are now running Epicor 9.05. This release brings with it an upgrade of Crystal Reports from XI to 2008. I’m not entirely sure what advantages this upgrade gives me, but I need to use it, for better or worse.

As of April 2012, the current recommended runtimes from Epicor are Crystal Reports 2008 SP3 (12.3.0.601), but of course what they ship on the media is the RTM release for CR Developer (12.0.0.549). And it turns out that it’s not unusual for folks to have trouble installing the RTM release.

What to do?

Answerbook # 13177MPS has some notes about installation best practices, but they suggest patching up from RTM through to SP3.

Forget that.

Head on over to SAP’s Business Objects Support Downloads and download yourself the full build for SP3. Choose Service Pack as the Software Type and it should show up. Install using your key and worry less.

Crystal Reports 2008 Label Formatting Issues?

We had some problems with Crystal Reports 2008 formatting our labels incorrectly, which caused us all kinds of weird problems. We’ve got 2.25” wide x 1.25” tall labels and it was having some orientation issues.

If you also run into a similar problem, what solved it for us was moving our Crystal Reports runtimes to SP4. You can grab them directly from SAP. It’s not an officially supported solution, but it works. SP5 is out too, and it even has a full installer. I’ve been running the Developer on my workstation for three months without any issues to speak of.

The runtimes can be found again on SAP’s Business Objects Support Downloads page, choosing Utility as the Software Type and they’ll be listed as a Redist Install. At the time of this writing, I don’t see the SP5 files on that site, but check the links below or Google and they’ll appear.

More information:

6 thoughts on “Installing Crystal Reports 2008 Developer for Epicor 9.05 and Label Format Issues

  1. For our implentation we need to develop some custom labels at 5.5″ wide X 2.5″ tall and no matter what I do, when I print the label comes out rotated 90 degrees so that the label spans two labels in the wrong orientation. Sounds like the same problem you were having. I’m a bit unclear on which runtime & developer I should be running to resolve this issue. So far all I have done is updated our developer installs to SP3 which resolved several other problems. All clients stil have the runtime that came with 9.05.604. So would just updating my developer to SP4 fix this or does the clients runtimes need to be updated to SP4 as well?

    • I’d suggest installing the SP4 runtimes (from SAP Business Objects) on a test computer to see if that solves the orientation issue. You may not need to update your developer install to SP4.

      • The Runtime alone seemed to resolve our label orientation problem. However, I could not find the RUNTIME SP4 on the SAP website, I ended up finding it on another website. Most downloads out there say Runtime, but are actually the developer SP4. A link to the SAP hosted download for the Runtime and Developer would be helpful to others.

        • For reference, the runtimes are listed on the SAP Business Objects Support Downloads site as Redist Install under the Utility category. I’ll add a note in my post to clarify. Thanks!

  2. Pingback: Epicor 9 and Crystal Reports | Marc's Blog

Leave a Reply

Your email address will not be published. Required fields are marked *