Installing Crystal Reports 2008 Developer for Epicor 9.05 and Label Format Issues

Here we are now running Epicor 9.05. This release brings with it an upgrade of Crystal Reports from XI to 2008. I’m not entirely sure what advantages this upgrade gives me, but I need to use it, for better or worse.

As of April 2012, the current recommended runtimes from Epicor are Crystal Reports 2008 SP3 (12.3.0.601), but of course what they ship on the media is the RTM release for CR Developer (12.0.0.549). And it turns out that it’s not unusual for folks to have trouble installing the RTM release.

What to do?

Answerbook # 13177MPS has some notes about installation best practices, but they suggest patching up from RTM through to SP3.

Forget that.

Head on over to SAP’s Business Objects Support Downloads and download yourself the full build for SP3. Choose Service Pack as the Software Type and it should show up. Install using your key and worry less.

Crystal Reports 2008 Label Formatting Issues?

We had some problems with Crystal Reports 2008 formatting our labels incorrectly, which caused us all kinds of weird problems. We’ve got 2.25” wide x 1.25” tall labels and it was having some orientation issues.

If you also run into a similar problem, what solved it for us was moving our Crystal Reports runtimes to SP4. You can grab them directly from SAP. It’s not an officially supported solution, but it works. SP5 is out too, and it even has a full installer. I’ve been running the Developer on my workstation for three months without any issues to speak of.

The runtimes can be found again on SAP’s Business Objects Support Downloads page, choosing Utility as the Software Type and they’ll be listed as a Redist Install. At the time of this writing, I don’t see the SP5 files on that site, but check the links below or Google and they’ll appear.

More information:

Installing Crystal Reports XI R2 Developer for Epicor 8.03.409

Installing the Crystal Reports Designer is a little bit of a pain. You start with the original, pre-service pack version. Then there’s patches upon patches to install, and Epicor suggests that you install them all–in order–to get up to speed. To confuse things futher, the latest runtimes for Vista/Vantage 8.03.409 is XI R2 .Net 3.0 Runtime SP5 but Epicor 9.04 uses SP6 (6.4, to be exact) and it’s been suggested to me by support to use SP6.4 with Vista. I haven’t experienced any issues running SP6 with 8.03, so that’s fine with me.

EpicWeb has Answerbooks # 11811MPS and 9592MPS with links to all the patches if you want to download them, but installing six patches is a little excessive, in my opinion.

The much more tolerable option is as follows:

  1. Download Crystal Reports XI R2A SP4 Full Build and install using the same key you got from Epicor. Don’t use the installer from your CD.
  2. Download Crystal Reports XI R2A SP6 Incremental Build and install.
  3. Check your version (Help -> About Crystal Reports) and make sure it matches 11.5.12.1838
  4. Be glad you didn’t have to install all those patches.
For what it’s worth, this should probably work on Epicor 9.04, but I’m not running it to know for sure (and frankly, I’m not sure how many people are running 9.04 at all).

More information: